package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\((\d+)\)`)
var str = `(g) sdf
(554)sdf
() Df
(434)sdf
(d) d
33
(33)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}