use strict;
my $str = '<set>
<item>
<id>1</id>
<title>title1</title>
</item>
<item>
<id>2</id>
<title>title2</title>
</item>
<item>
<id>3</id>
<title>title3</title>
<img>img3</img>
</item>
</set>';
my $regex = qr~<item>.*?<id>((?:(?!<id>).)*?)</id>(?:(?!<item>).)*<img>(.*?)</img>.*?</item>~sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}