$re = '~<item>.*?<id>((?:(?!<id>).)*?)</id>(?:(?!<item>).)*<img>(.*?)</img>.*?</item>~si';
$str = '<set>
<item>
<id>1</id>
<title>title1</title>
</item>
<item>
<id>2</id>
<title>title2</title>
</item>
<item>
<id>3</id>
<title>title3</title>
<img>img3</img>
</item>
</set>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);