const regex = /0-((?:(?!0-).)*)\.htm/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0-((?:(?!0-).)*)\\.htm', '')
const str = `http://www.someurl.com/some-text-1-0-1-0-some-text.htm#id_76`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}