import Foundation
let pattern = #"0-((?:(?!0-).)*)\.htm"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"http://www.someurl.com/some-text-1-0-1-0-some-text.htm#id_76"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}