$re = '/0-((?:(?!0-).)*)\.htm/';
$str = 'http://www.someurl.com/some-text-1-0-1-0-some-text.htm#id_76';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);