import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(\\*\\*-+\\*\\*)\\\\$(.*?)^\\\\\\1\\/$|.";
final String string = "/**--------------------------------------------------------------------------**\\\n"
+ "<summary>FunctionName</summary>\n"
+ "<returns>\n"
+ " Returns 1 on success.\n"
+ " Returns 0 on failure.\n"
+ "</returns>\n"
+ "<remarks>\n"
+ " This function is a function.\n"
+ "</remarks>\n"
+ "\\**--------------------------------------------------------------------------**/\n\n"
+ "int FunctionName()\n"
+ "{\n"
+ " int X = 1;\n"
+ " if(X == 1)\n"
+ " return 1;\n"
+ " return 0;\n"
+ "}";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}