using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z0-9]+)\s+([\w\-]+)(.+?)\s([a-z0-9]+)\s([0-9]+)";
string substitution = @"LOCAL_INTERFACE = \1\nNEIGHBOR = \2\nNEIGHBOR_INTERFACE = \4";
string input = @"Et1 lab-fr-sw01.test.local Ethernet24 120";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}