$re = '/([a-z0-9]+)\s+([\w\-]+)(.+?)\s([a-z0-9]+)\s([0-9]+)/mi';
$str = 'Et1 lab-fr-sw01.test.local Ethernet24 120';
$subst = "LOCAL_INTERFACE = \1\nNEIGHBOR = \2\nNEIGHBOR_INTERFACE = \4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;