const regex = new RegExp('([a-z0-9]+)\\s+([\\w\\-]+)(.+?)\\s([a-z0-9]+)\\s([0-9]+)', 'gmi')
const str = `Et1 lab-fr-sw01.test.local Ethernet24 120`;
const subst = `LOCAL_INTERFACE = \1\nNEIGHBOR = \2\nNEIGHBOR_INTERFACE = \4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);