package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^"\n\\]*(?:\\.[^"\n\\]*)*$`)
var str = `The cow jumped over the \"moon
The cow jumped over the "moon`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}