$re = '/^[^"\n\\\\]*(?:\\\\.[^"\n\\\\]*)*$/m';
$str = 'The cow jumped over the \\"moon
The cow jumped over the "moon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);