re = /^[^"\n\\]*(?:\\.[^"\n\\]*)*$/m
str = 'The cow jumped over the \\"moon
The cow jumped over the "moon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end