import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<property[^>]*name=\"(username|password)[^>]*>[^<]*</property>";
final String string = "<property name=\"password\">QWERTY</property>\n"
+ "....lots of similar tags......\n"
+ "<property name=\"username\">Hello</property>\n"
+ "<property name=\"passive\">1</property>\n"
+ "<property name=\"password\">Test Password</property><property name=\"scheme\">smb</property>\n\n"
+ "<property name=\"timeout\">10000</property>\n"
+ "<property name=\"username\">RANDOM USER</property>\n"
+ "....lots of similar tags......\n"
+ "<property name=\"username\">Sid</property>\n"
+ "<property name=\"passive\">1</property><property name=\"username\">Hello</property>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}