# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<property[^>]*name=\"(username|password)[^>]*>[^<]*</property>"
test_str = ("<property name=\"password\">QWERTY</property>\n"
"....lots of similar tags......\n"
"<property name=\"username\">Hello</property>\n"
"<property name=\"passive\">1</property>\n"
"<property name=\"password\">Test Password</property><property name=\"scheme\">smb</property>\n\n"
"<property name=\"timeout\">10000</property>\n"
"<property name=\"username\">RANDOM USER</property>\n"
"....lots of similar tags......\n"
"<property name=\"username\">Sid</property>\n"
"<property name=\"passive\">1</property><property name=\"username\">Hello</property>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.