// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<property[^>]*name="(username|password)[^>]*>[^<]*</property>"#).unwrap();
let string = "<property name=\"password\">QWERTY</property>
....lots of similar tags......
<property name=\"username\">Hello</property>
<property name=\"passive\">1</property>
<property name=\"password\">Test Password</property><property name=\"scheme\">smb</property>
<property name=\"timeout\">10000</property>
<property name=\"username\">RANDOM USER</property>
....lots of similar tags......
<property name=\"username\">Sid</property>
<property name=\"passive\">1</property><property name=\"username\">Hello</property>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}