const regex = /(^|^[^:]+:\/\/|[^\.]+\.)hello\.net/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|^[^:]+:\\\/\\\/|[^\\.]+\\.)hello\\.net', 'gm')
const str = `http://hello.net
https://hello.net
http://www.hello.net
https://www.hello.net
http://domain.hello.net
https://solutions.hello.net
hello.net
www.hello.net
hello.net.domain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}