#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)^(.*?)(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?$"
Local $sString = "1.jpg 2.jpg 3.jpg 4.jpg 5.jpg 6.jpg 7.jpg 8.jpg 9.jpg 10.jpg 11.jpg 12.jpg 13.jpg 14.jpg 15.jpg 16.jpg 17.jpg 18.jpg 19.jpg 20.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")