// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)^(.*?)(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?$").unwrap();
let string = "1.jpg 2.jpg 3.jpg 4.jpg 5.jpg 6.jpg 7.jpg 8.jpg 9.jpg 10.jpg 11.jpg 12.jpg 13.jpg 14.jpg 15.jpg 16.jpg 17.jpg 18.jpg 19.jpg 20.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}