import re
regex = re.compile(r"""
^(.*?)(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?(?:\s(.+?))?$
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = "1.jpg 2.jpg 3.jpg 4.jpg 5.jpg 6.jpg 7.jpg 8.jpg 9.jpg 10.jpg 11.jpg 12.jpg 13.jpg 14.jpg 15.jpg 16.jpg 17.jpg 18.jpg 19.jpg 20.jpg"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")