import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(traffic|bot|website)-?(bot|traffic|website|4free)";
final String string = "trafficbot bot-website\n"
+ "traffic-bot traffic4free\n"
+ "bot-traffic traffic-4free\n"
+ "bottraffic website-4free\n"
+ "bottraffic4free bot-4free\n"
+ "websitebottraffic bot4free\n"
+ "getbottraffic4free trafficbot4free\n"
+ "easy-website-traffic automatedtraffic4free\n"
+ "traffic-website ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}