re = /(traffic|bot|website)-?(bot|traffic|website|4free)/m
str = 'trafficbot bot-website
traffic-bot traffic4free
bot-traffic traffic-4free
bottraffic website-4free
bottraffic4free bot-4free
websitebottraffic bot4free
getbottraffic4free trafficbot4free
easy-website-traffic automatedtraffic4free
traffic-website '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end