import re
regex = re.compile(r"(traffic|bot|website)-?(bot|traffic|website|4free)", flags=re.MULTILINE)
test_str = ("trafficbot bot-website\n"
"traffic-bot traffic4free\n"
"bot-traffic traffic-4free\n"
"bottraffic website-4free\n"
"bottraffic4free bot-4free\n"
"websitebottraffic bot4free\n"
"getbottraffic4free trafficbot4free\n"
"easy-website-traffic automatedtraffic4free\n"
"traffic-website ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")