import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/\\s*|https:\\/\\/\\s*|ftp:\\/\\/\\s*)?(www\\s*)?(?(1)([.]\\s*))?(?(2)([.]\\s*))?([a-zA-Z0-9.-]{2,256})(\\s*[.]\\s*)(ru|pl|kz|by|ua|com|in|pt|br|co.uk)(?![a-zA-Z])([?|#]{1}[=&#a-zA-Z0-9]{2,128})?";
final String string = "http:// www . alga-deweloper . pl\n"
+ "TIRA UM: Ńąm iuvaret tus electram. Tempor http://www.google.com in eam, ut dictas disputando vim.\n"
+ "NO TIRA: kuchnia.Na impedit ne, cu pri vęri nostro, mel ut integre praesent dissentias.\n"
+ "TIRA UM: Ceteros inćorruptę google.com?sad=asd id, saępe ńullam vix ut.\n"
+ "TIRA UM: Eam ut ępićurei adólesćens. Nam ąd sumo agąm. Vis te dicam https://www.google.com.\n"
+ "TIRA UM: Has ęa, ei cóngue tęmpóribus comprehęnsam http://asdasd asdas da www.amazon.co.uk.\n"
+ "NÃ TIRA: No nónumy doćtus sd.asd.comia uma pizza.nan asjJ.domain djJ.co asd.uk, altęra cónśetetur ut.\n"
+ "SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam http:// asdasdasd . com Cu vix.\n"
+ "SECRETO: Hinc expetenda ocurreret at has. Ex eum ętiam www . asdasdasd . com Cu vix.\n"
+ "SECRETO: http:// www . alga-deweloper . pl sdsdfsdfsdf\n"
+ "NÃ TIRA: Altęra cónśetetur ut ?asd=asdd asdasd sdfsdfsdfsdf.\n"
+ "TIRA UM: Ceteros inćorruptę http://www.google6.com#sdfsdf id, saępe ńullam vix ut.\n"
+ "TIRA UM: Ceteros inćorruptę http://www.google6.com?asdads=asd&asasd=sdasd#sdfsdf id, ńullam vix ut.\n"
+ "TIRA UM: Altęra cónśetetur www.donet.come sdffd. domain . com asdasd\n"
+ "TIRA UM: Altęra cónśetetur www.donet.come sdffd. www . aasd . com asdasd\n"
+ "TIRA UM: http:// www . alga-deweloper . pl";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}