#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(#{1,6})\ h[1-6](\ \1)?"
Local $sString = "# h1" & @CRLF & _
"## h2" & @CRLF & _
"### h3" & @CRLF & _
"#### h4" & @CRLF & _
"##### h5" & @CRLF & _
"###### h6" & @CRLF & _
"# h1 #" & @CRLF & _
"## h2 ##" & @CRLF & _
"### h3 ###" & @CRLF & _
"#### h4 ####" & @CRLF & _
"##### h5 #####" & @CRLF & _
"###### h6 ######"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")