import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(#{1,6})\\ h[1-6](\\ \\1)?";
final String string = "# h1\n"
+ "## h2\n"
+ "### h3\n"
+ "#### h4\n"
+ "##### h5\n"
+ "###### h6\n"
+ "# h1 #\n"
+ "## h2 ##\n"
+ "### h3 ###\n"
+ "#### h4 ####\n"
+ "##### h5 #####\n"
+ "###### h6 ######";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}