re = /(#{1,6})\ h[1-6](\ \1)?/
str = '# h1
## h2
### h3
#### h4
##### h5
###### h6
# h1 #
## h2 ##
### h3 ###
#### h4 ####
##### h5 #####
###### h6 ######'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end