const regex = /^01[0125][0-9]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^01[0125][0-9]{8}$', 'gm')
const str = `01012345678
01112345678
01212345678
01512345678
01312345678
010123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}