import re
regex = re.compile(r"^01[0125][0-9]{8}$", flags=re.MULTILINE)
test_str = ("01012345678\n"
"01112345678\n"
"01212345678\n"
"01512345678\n"
"01312345678\n"
"010123456789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")