re = /^01[0125][0-9]{8}$/m
str = '01012345678
01112345678
01212345678
01512345678
01312345678
010123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end