package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(или\s[a-zA-Z\s(),.'!]+\s`)
var str = `to hold (или to keep) (oneself) aloof (from), (или turn)! to stand aloof smb's (или to hello) smth. мне очень хочется повидать его`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}