const regex = /\(или\s[a-zA-Z\s(),.'!]+\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(или\\s[a-zA-Z\\s(),.\'!]+\\s', 'gm')
const str = `to hold (или to keep) (oneself) aloof (from), (или turn)! to stand aloof smb's (или to hello) smth. мне очень хочется повидать его`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}