import re
regex = re.compile(r"\(или\s[a-zA-Z\s(),.'!]+\s", flags=re.MULTILINE)
test_str = "to hold (или to keep) (oneself) aloof (from), (или turn)! to stand aloof smb's (или to hello) smth. мне очень хочется повидать его"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")