#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[?&](abcustomerid=\d+)"
Local $sString = "/the/stucture/blah.php?timeout=300&abcustomerid=53122&customer=zxyi" & @CRLF & _
"/some/other/struct/pagehere.php?today=Thursday&abcustomerid=241&count=54" & @CRLF & _
"/blah/blah/tendid.php?abcustomerid=12525"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")