import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[?&](abcustomerid=\\d+)";
final String string = "/the/stucture/blah.php?timeout=300&abcustomerid=53122&customer=zxyi\n"
+ "/some/other/struct/pagehere.php?today=Thursday&abcustomerid=241&count=54\n"
+ "/blah/blah/tendid.php?abcustomerid=12525";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}