package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[?&](abcustomerid=\d+)`)
var str = `/the/stucture/blah.php?timeout=300&abcustomerid=53122&customer=zxyi
/some/other/struct/pagehere.php?today=Thursday&abcustomerid=241&count=54
/blah/blah/tendid.php?abcustomerid=12525`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}