#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^a-zA-Z\d]*)([a-zA-Z\d]*)"
Local $sString = "!@#1$%* ABC def:123" & @CRLF & _
"" & @CRLF & _
"err1or one! a(t&(\)Ct!0n" & @CRLF & _
"" & @CRLF & _
"i select 4llsp&&&cial char!!?!???!?!" & @CRLF & _
"" & @CRLF & _
"#tag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")