import re
regex = re.compile(r"([^a-zA-Z\d]*)([a-zA-Z\d]*)")
test_str = ("!@#1$%* ABC def:123\n\n"
"err1or one! a(t&(\\)Ct!0n\n\n"
"i select 4llsp&&&cial char!!?!???!?!\n\n"
"#tag")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")