package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^a-zA-Z\d]*)([a-zA-Z\d]*)`)
var str = `!@#1$%* ABC def:123
err1or one! a(t&(\)Ct!0n
i select 4llsp&&&cial char!!?!???!?!
#tag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}