const regex = /^[A-Z0-9]{18}[0-9]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z0-9]{18}[0-9]{2}$', 'gm')
const str = `AAAAAAAAAAAAAAAAAA11
AAAAAAAAAAAAAAAAAAA1
AAAAAAAAAAAAAAAAAA1A
ABCDEFGHIJ1234567890
ABCDEFGHIJ12345678901
12345678901234567890
123456789012345678901
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}