import Foundation
let pattern = #"^[A-Z0-9]{18}[0-9]{2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AAAAAAAAAAAAAAAAAA11
AAAAAAAAAAAAAAAAAAA1
AAAAAAAAAAAAAAAAAA1A
ABCDEFGHIJ1234567890
ABCDEFGHIJ12345678901
12345678901234567890
123456789012345678901
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)