import re
regex = re.compile(r"^[A-Z0-9]{18}[0-9]{2}$", flags=re.MULTILINE)
test_str = ("AAAAAAAAAAAAAAAAAA11\n"
"AAAAAAAAAAAAAAAAAAA1\n"
"AAAAAAAAAAAAAAAAAA1A\n"
"ABCDEFGHIJ1234567890\n"
"ABCDEFGHIJ12345678901\n"
"12345678901234567890\n"
"123456789012345678901\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")