# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\d]+)\b//g;t' <<< "Lorem ipsum dolor sit amet, consectetur adipiscing elit. _4,7,13 Nullam suscipit orci sit amet feugiat facilisis. Curabitur eget 8 ligula malesuada, vehicula 3,6 quam sit amet, _5 tempor velit."