using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:[^][]++|(?R))*+\]\K(\d{2}/\d{2}/\d{4})\h+([^[]+)";
string input = @"[vc_row][vc_column width=""1/1""]28/04/2015 Text description[vc_row][vc_column width=""1/1""][vc_row][vc_column width=""1/1""]29/04/2015 Text description 2[vc_row][vc_column width=""1/1""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}