import Foundation
let pattern = #"\[(?:[^][]++|(?R))*+\]\K(\d{2}/\d{2}/\d{4})\h+([^[]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[vc_row][vc_column width="1/1"]28/04/2015 Text description[vc_row][vc_column width="1/1"][vc_row][vc_column width="1/1"]29/04/2015 Text description 2[vc_row][vc_column width="1/1"]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)