import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:[^][]++|(?R))*+\\]\\K(\\d{2}/\\d{2}/\\d{4})\\h+([^[]+)";
final String string = "[vc_row][vc_column width=\"1/1\"]28/04/2015 Text description[vc_row][vc_column width=\"1/1\"][vc_row][vc_column width=\"1/1\"]29/04/2015 Text description 2[vc_row][vc_column width=\"1/1\"]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}