use strict;
my $str = 't=APTO&ty=c&p=d&b=1">13.49M</a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1">-</a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1"><span style="color:#008800;">1.53</span></a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1"><span style="color:#008800;">53.00%</span></a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1">8,030,287</a>, <a class="screener-link" href="quote.ashx?t=EVOK&ty=c&p=d&b=1">2</a>, <a class="screener-link"
';
my $regex = qr/\b\d+(?:\.\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}