import re
regex = re.compile(r"\b\d+(?:\.\d+)")
test_str = ("t=APTO&ty=c&p=d&b=1\">13.49M</a>, <a class=\"screener-link\" href=\"quote.ashx?t=APTO&ty=c&p=d&b=1\">-</a>, <a class=\"screener-link\" href=\"quote.ashx?t=APTO&ty=c&p=d&b=1\"><span style=\"color:#008800;\">1.53</span></a>, <a class=\"screener-link\" href=\"quote.ashx?t=APTO&ty=c&p=d&b=1\"><span style=\"color:#008800;\">53.00%</span></a>, <a class=\"screener-link\" href=\"quote.ashx?t=APTO&ty=c&p=d&b=1\">8,030,287</a>, <a class=\"screener-link\" href=\"quote.ashx?t=EVOK&ty=c&p=d&b=1\">2</a>, <a class=\"screener-link\" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")