$re = '/\b\d+(?:\.\d+)/';
$str = 't=APTO&ty=c&p=d&b=1">13.49M</a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1">-</a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1"><span style="color:#008800;">1.53</span></a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1"><span style="color:#008800;">53.00%</span></a>, <a class="screener-link" href="quote.ashx?t=APTO&ty=c&p=d&b=1">8,030,287</a>, <a class="screener-link" href="quote.ashx?t=EVOK&ty=c&p=d&b=1">2</a>, <a class="screener-link"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);