const regex = /-\s(.*)\n?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\s(.*)\\n?', 'gmi')
const str = `- Abonnement Standard
- Support Standard
- 2 Canaux
- Définition de la stratégie de ciblage par un chef de produit dédié
- Suivi mensuel des performances et optimisation de la stratégie de ciblage
- Configuration et intégration
- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive
- Formation à distance - 2 heures - 5 personnes
- Option Genius Targeting
- Option Genius Answers`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}